package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-Z]?[a-z]+|[A-Z]|[0-9]+`)
var str = `ANet15Amount`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}