import Foundation
let pattern = #"^(.)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Work
Work
Fire
Global{"dmids":[200000298206588]}
{"dmids":[200000298207769,200000315647883]}
{"dmids":[200000298207847,200000298559762,200000298729095,200000298937045,200000299376139,200000337459486,200000339993204,2000000298149778]}
{"dmids":[200000298208329,200000298316016,200000298560524,200000300915842,2000000298179810,2000000298180861]}
{"dmids":[200000298208335,200000298316025,200000298560517,200000300915858,2000000298179808,2000000298180858]}
{"dmids":[200000298208343,200000298316014,200000298560521,200000300915848,2000000298179798,2000000298180857]}
{"dmids":[200000298210597,200000299898455,200000299949910,200000304060818,200000305323250,2000000298190262]}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)