$re = '/\/\/[ ]*MARK[ \t]*:*[ \t]*(?:(?!ABCD)[^\n])*$/m';
$str = '//MARK: MarABdasdsd
//MARK sthIsHere
//MARK: great marABCDE';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);