$re = '/<a href="(.*?)"> Read more\.\.\.<\/a>/';
$str = '"Overview bla bla . It is<a href="http://test.com/portfolio/wadf/"> Read more...</a>"';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);