import Foundation
let pattern = #"([^\s\{]+?(?=:))(:\s)([^;]*);"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
width: 220px;
height: 50px;
border-radius: 2px;
background-color: #269ce2;
box-shadow: 0 1px 2px 0 rgba(0, 0, 0, 0.12);
border: solid 1px #228cc9;
font-family: AvenirNext-Medium;
font-size: 16px;
text-align: center;
color: #ffffff;
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #":$1 "$3""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)