re = /TR\s+@(\w+):/
str = 'TR @abcnews:
TR @huehueeeeeeeeeeeeee:
TR $psdaoif not this:'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end