package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<([a-z]+)((?:[^<]|<%)*)(style)="([^"]*)"([^<]*)>`)
var str = `<a href="<%= url %>" style="color:#000">Link</a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}