$re = '/workmail: mail:\s*([^@>;]*)/';
$str = 'homemail: mail:username@mail.com
workmail: mail:username@mail.com
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);