# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/"([^<>]*?)"(?=[^>]+?<)/\<em\>\1\<\\/em\>/g;t' <<< "<p>This is a \"wonderful long text\". \"Another wonderful ong text\" At least it should be. Here we have a <a href=\"http://wwww.site-to-nowhere.com\" target=\"_blank\">link</a>.</p>
"