import Foundation
let pattern = #""([^<>]*?)"(?=[^>]+?<)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<p>This is a "wonderful long text". "Another wonderful ong text" At least it should be. Here we have a <a href="http://wwww.site-to-nowhere.com" target="_blank">link</a>.</p>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\<em\>\1\<\/em\>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)