#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\[\s*youku\s*:\s*([^]]*)\]"
Local $sString = "Hello [youku: xxAAAJFSK] This is a test." & @CRLF & _
"Hello2 This is test2 [ youku : y8d78fd]." & @CRLF & _
"Hello3 This is test3 [ youku" & @CRLF & _
"" & @CRLF & _
": 484fsfs]."
Local $sSubst = "<iframe src="http://player.youku.com/embed/$1"></iframe>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)