$re = '/^(?=.*[0-9])(?=.*[a-z])[0-9a-z-]{17}$/i';
$str = 'AB^DF31U100027743';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);