package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*((?:lower|upper)-.*?)-`)
var str = `upper-lower-upper-lower-sometext-
lower-upper-moretext-
lower-andmoretext-`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}