using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^path(?:\?([^#\n]+))?(?=#|$)";
string input = @"path?foo=67
path?foo=67&bar=hello
path?bar=bye&foo=1&baz=12
path?bar=123
path
path#anchor
path?bar=bye#&foo=123
path?bar=bye&foo=-123#&foo=123
path?foo=37signals
path?foo=-8
something?foo=1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}