import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^path(?:(?=\\?)(?:[?&]foo=\\d*(?=[&#]|$)|(?![?&]foo=)[^#\\n])+)?(?=#|$)";
final String string = "path?foo=67\n"
+ "path?foo=67&bar=hello\n"
+ "path?bar=bye&foo=1&baz=12\n"
+ "path?bar=123\n"
+ "path\n"
+ "path#anchor\n"
+ "path?bar=bye#&foo=123\n"
+ "path?bar=bye&foo=-123#&foo=123\n"
+ "path?foo=37signals\n"
+ "path?foo=-8\n"
+ "something?foo=1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}