using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=\w+\()\w+?\(([\s'!\\\)"",\w]+)+\);";
string input = @"_(""hello""); // should grab ""hello""
_('foo""!\'bar'); // should grab ""foo""!\'bar""
_t(""hello\""!)' you""); // should grab ""hello\""!)' you""
_n(""foo"", ""bar"", 4); // should grab ""foo"" and ""bar""
_n('foo', 'bar', 4);
{{_ ""hello"" }}
{{_t ""hello"" }}
{{_n ""hello {{ count }}"" ""{{ count }} bar"" count=""4"" }}
gettext(""foo""); // should grab ""foo""
ngettext(""bar"", ""baz"", 42); // should grab ""bar"" and ""baz""
dgettext(domain, ""bux""); // should grab ""bux""
_( ""bar"" );
_n( ""baz"", ""bux"", 42);";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}