import Foundation
let pattern = #"^(?=\w+\()\w+?\(([\s'!\\\)",\w]+)+\);"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
_("hello"); // should grab "hello"
_('foo"!\'bar'); // should grab "foo"!\'bar"
_t("hello\"!)' you"); // should grab "hello\"!)' you"
_n("foo", "bar", 4); // should grab "foo" and "bar"
_n('foo', 'bar', 4);
{{_ "hello" }}
{{_t "hello" }}
{{_n "hello {{ count }}" "{{ count }} bar" count="4" }}
gettext("foo"); // should grab "foo"
ngettext("bar", "baz", 42); // should grab "bar" and "baz"
dgettext(domain, "bux"); // should grab "bux"
_( "bar" );
_n( "baz", "bux", 42);
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)