$re = '/(?<=pies\n|\G,\n)(\w+ likes)/m';
$str = 'pies
bob likes,
larry likes,
harry likes
cakes';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);