re = /name:\s(.*),\slocation:\s(.*),\sdescription:\s(.*),\sskills:\s(.*)/
str = 'name: jo mamma, location: Atlanta, Georgia, description: He is a good boy, and he is pretty funny, skills: not much at all!'
# Print the match result
str.match(re) do |match|
puts match.to_s
end