#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[A-Za-z0-9*&@]+"
Local $sString = "abc" & @CRLF & _
"123" & @CRLF & _
"abc@123" & @CRLF & _
"abc@123.com" & @CRLF & _
"abc&*@domain.com" & @CRLF & _
"1&2&3@abc@ABC@123@123@123@123@123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")