re = /[A-Za-z0-9*&@]+/m
str = 'abc
123
abc@123
abc@123.com
abc&*@domain.com
1&2&3@abc@ABC@123@123@123@123@123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end