const regex = /(?!^)\b(\w)\w+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!^)\\b(\\w)\\w+', 'gm')
const str = `John Smith
Kim Jong Un
David X. Cohen
Bob`;
const subst = `$1.`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);