package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m){gop:include\s*name=[^\s]*\s*}`)
var str = `I'm at Harrah's Hotel and Casino: Luxury Suite (New Orleans, LA) w/ 2 others http://t.co/UjxTIdiJ{gop:include name='template'}{gop:include name="tempe3late"}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}