const regex = /{gop:include\s*name=[^\s]*\s*}/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{gop:include\\s*name=[^\\s]*\\s*}', 'mg')
const str = `I'm at Harrah's Hotel and Casino: Luxury Suite (New Orleans, LA) w/ 2 others http://t.co/UjxTIdiJ{gop:include name='template'}{gop:include name="tempe3late"}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}