const regex = /\s*(.*\{\{while\s+.*(?:\r?\n.*)+\{\{while\s+end.*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*(.*\\{\\{while\\s+.*(?:\\r?\\n.*)+\\{\\{while\\s+end.*)', '')
const str = `<html lang="{{var doc-lang}}">
<head>
<title>{{var doc-title}}</div>
</head>
<body>
<div class="container">
<div class="row" {{while products}}>
{{var name}}
{{var sku}}
{{var barcode}}
</div {{while end}}>
</div>
</body>
</html>`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);