import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img.*src=\"(.*\\)";
final String string = "<img style=\"gdgdF\" src=\"http://multimedia.pol.dk/archive/00802/RB_PLUS_Danskerne___802815p.jpg\" width=\"369\" height=\"253\" alt=\"SPRITKONTROL\" />";
final String subst = "<img src=\"http://multimedia.pol.dk/archive/00802/SNOOTS.jpg\"";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}