import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\"[^\\\"]*[\\u2E80-\\u9FFF]+[^\\\"]*\\\"";
final String string = "// case ph_text_fill_item:\n"
+ "// v[TEST_TYPE_TEXT] = W2U(L\"填空题\");\n"
+ "// ((CTextRectObj*)pObjs[i])->SetTestAttrs(v);\n"
+ "// break;\n"
+ "// case ph_text_answer_fill_item:\n"
+ "// v[TEST_TYPE_TEXT] = W2U(L\"解答题\");\n"
+ "// ((CTextRectObj*)pObjs[i])->SetTestAttrs(v);\n"
+ "// break;\n"
+ "// case ph_text_answer_trueorfalse:\n"
+ "// v[TEST_TYPE_TEXT] = W2U(L\"判断题\");\n"
+ "// ((CTextRectObj*)pObjs[i])->SetTestAttrs(v);\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}