import re
regex = re.compile(r"\"[^\"]*[\u2E80-\u9FFF]+[^\"]*\"")
test_str = ("// case ph_text_fill_item:\n"
"// v[TEST_TYPE_TEXT] = W2U(L\"填空题\");\n"
"// ((CTextRectObj*)pObjs[i])->SetTestAttrs(v);\n"
"// break;\n"
"// case ph_text_answer_fill_item:\n"
"// v[TEST_TYPE_TEXT] = W2U(L\"解答题\");\n"
"// ((CTextRectObj*)pObjs[i])->SetTestAttrs(v);\n"
"// break;\n"
"// case ph_text_answer_trueorfalse:\n"
"// v[TEST_TYPE_TEXT] = W2U(L\"判断题\");\n"
"// ((CTextRectObj*)pObjs[i])->SetTestAttrs(v);\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")