$re = '/(?<![)(]),(?![)(])/';
$str = 'test,test
test),test
test,)test
test),)test
test(,test
test,(test
test(,(test
test(,)test
test),(test
a,c,b, d
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);