package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)<head>\s*([\s\S]*?)\s*<\/head>`)
var str = `<html lang="en">
<head>
<meta http-equiv ...............
...................
</head> ..............
...............
</html>`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}