const regex = /^(?!.*\b(?:the|ones|that|should|not|match)\b)(?=.*\b(?:words|I|want|to|include)\b).*$/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*\\b(?:the|ones|that|should|not|match)\\b)(?=.*\\b(?:words|I|want|to|include)\\b).*$', 'gim')
const str = `Words I know
Words that I know
I want to watch this
I want to watch that
To include everyone
To include the ones
He wants ice-cream (doesn't m@tch as "wants" != "w@nt")
We want to see him include
We want to see him include that option`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}