$re = '/\b(?<!\$)(?:print|time)\b/';
$str = 'print $time . "\\n";
$epoc = time();';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);