#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)(\b(https?|ftp|file):?(www)?\/\/[-\w+&@#\/%?=~_|!:,.;]*[-\w+&@#\/%=~_|])"
Local $sString = "www.google.fr"
Local $sSubst = "<a href='$1'>$1</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)