import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\b(https?|ftp|file):?(www)?\\/\\/[-\\w+&@#\\/%?=~_|!:,.;]*[-\\w+&@#\\/%=~_|])";
final String string = "www.google.fr";
final String subst = "<a href='$1'>$1</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}