// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(\b(https?|ftp|file):?(www)?\/\/[-\w+&@#\/%?=~_|!:,.;]*[-\w+&@#\/%=~_|])").unwrap();
let string = "www.google.fr";
let substitution = "<a href='$1'>$1</a>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}