import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?is)\\[quote\\]((?&core)|)\\[\\/quote\\]$(?(DEFINE)(?<core>(?>(?&content)|\\[quote\\](?:(?&core)|)\\[\\/quote\\])+)(?<content>(?>(?!\\[\\/?quote\\]).)+))";
final String string = "Here is the example post text\n\n"
+ "[QUOTE]\n"
+ "This is an appropriate quote\n"
+ "[/QUOTE]\n\n"
+ "Here is more post content\n\n"
+ "[QUOTE]\n"
+ "This is an unnecessary quote, as it's below all of the post text\n"
+ " [QUOTE]\n"
+ " Here's an unnecessary nested quote, just to confuse things.\n"
+ " [/QUOTE]\n"
+ "[/QUOTE]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}