import Foundation
let pattern = #"var (?:(?!var).)*?=function.*11"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"var abc1=function(_x1,_y1){var a=1,b=2,c=3};var abc2=function(_x2,_y2){var a=4,b=5,c=6};var abc3=function(_x3,_y3){var a=7,b=8,c=9};var abc4=function(_x4,_y4){var a=10,b=11,c=12};var abc5=function(_x5,_y5){var a=13,b=14,c=15}"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)