import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[[^#]*#\\K\\d{1,16}";
final String string = "I made a commit [#12345678] to a story\n"
+ "[finished #12345678] Made a commit\n"
+ "[fixed #12345678] Made a commit\n"
+ "[complete #12345678] Made a commit";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}