#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([+-]?\b\d+\b)|\S+[ \t]*"
Local $sString = "0 | success. id - 1234|" & @CRLF & _
"" & @CRLF & _
"-10 | failure. id - 2345" & @CRLF & _
""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)