const regex = /([+-]?\b\d+\b)|\S+[ \t]*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([+-]?\\b\\d+\\b)|\\S+[ \\t]*', 'g')
const str = `0 | success. id - 1234|
-10 | failure. id - 2345
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);