$re = '/([+-]?\b\d+\b)|\S+[ \t]*/';
$str = '0 | success. id - 1234|
-10 | failure. id - 2345
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;