re = /([+-]?\b\d+\b)|\S+[ \t]*/
str = '0 | success. id - 1234|
-10 | failure. id - 2345
'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result