re = /^(?=.{8,15}$)(?=.*[A-Za-z])(?=.*\d)(?!.*?(.)\1{3})[A-Za-z0-9]+$/m
str = 'abcdedsnnsd
abcdedddddd
abxj12256765762'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end