#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([A-Za-z]+)\s([A-Za-z]+)\s([A-Z]{2})\s([0-9]+)\s([A-Za-z]+)(\s+)([A-Z])\s([0-9]{1,2})\/([0-9]{1,2})\/([0-9]{4}\s)([0-9]{1,2}):([0-9]{1,2})\s"
Local $sString = "Frankfurt Izmir XQ 971 SunEco A 13/03/2016 14:55 AINT9 HK 30 " & @CRLF & _
"Izmir Trabzon XQ 9270 SunEco S 13/03/2016 20:10 SADDOND HK 30 " & @CRLF & _
"Trabzon Antalya XQ 7619 SunEco S 31/03/2016 12:00 SADDOND HK 30 " & @CRLF & _
"Antalya Frankfurt XQ 140 SunEco Z 31/03/2016 15:00 ZINT8 HK 30"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")