import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Za-z]+)\\s([A-Za-z]+)\\s([A-Z]{2})\\s([0-9]+)\\s([A-Za-z]+)(\\s+)([A-Z])\\s([0-9]{1,2})\\/([0-9]{1,2})\\/([0-9]{4}\\s)([0-9]{1,2}):([0-9]{1,2})\\s";
final String string = "Frankfurt Izmir XQ 971 SunEco A 13/03/2016 14:55 AINT9 HK 30 \n"
+ "Izmir Trabzon XQ 9270 SunEco S 13/03/2016 20:10 SADDOND HK 30 \n"
+ "Trabzon Antalya XQ 7619 SunEco S 31/03/2016 12:00 SADDOND HK 30 \n"
+ "Antalya Frankfurt XQ 140 SunEco Z 31/03/2016 15:00 ZINT8 HK 30";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}