re = /([A-Za-z]+)\s([A-Za-z]+)\s([A-Z]{2})\s([0-9]+)\s([A-Za-z]+)(\s+)([A-Z])\s([0-9]{1,2})\/([0-9]{1,2})\/([0-9]{4}\s)([0-9]{1,2}):([0-9]{1,2})\s/
str = 'Frankfurt Izmir XQ 971 SunEco A 13/03/2016 14:55 AINT9 HK 30
Izmir Trabzon XQ 9270 SunEco S 13/03/2016 20:10 SADDOND HK 30
Trabzon Antalya XQ 7619 SunEco S 31/03/2016 12:00 SADDOND HK 30
Antalya Frankfurt XQ 140 SunEco Z 31/03/2016 15:00 ZINT8 HK 30'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end