import re
regex = re.compile(r"(^|[\.\?\!\-]\s|)([A-ZÃ-ÚÑ][^¿¡\!\?\.]+)((\.{3})?\?)")
test_str = ("Qué dices? Eso es...? No entiendo.\n"
"Adrian y Pedro lo saben? - SÃ, no lo sabÃas?")
subst = "$1¿$2$3"
result = regex.sub(subst, test_str)
if result:
print(result)