// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"'file' *: *'([^']*)'").unwrap();
let string = "<script type=\"text/javascript\">
jwplayer('player_container').setup(
{
'width': '640',
'height': '384',
'players': [ {type: 'flash', src: '/player/player.swf'} ],
'file':'http://video.sibnet.ru/v/98a6a9525d30afd623457f445ca95199/1321852.mp4',
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}