#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:<?+\$(\d+))?-?(?:>?(\d+)k)?"
Local $sString = "<$10k" & @CRLF & _
"$10-20k" & @CRLF & _
"$20-30k" & @CRLF & _
"$30-40k" & @CRLF & _
"$40-50k" & @CRLF & _
"$50-75k" & @CRLF & _
"$75-100k" & @CRLF & _
"$100-150k" & @CRLF & _
">150k" & @CRLF & _
"Don't know/refused" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")