package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:<?+\$(\d+))?-?(?:>?(\d+)k)?`)
var str = `<$10k
$10-20k
$20-30k
$30-40k
$40-50k
$50-75k
$75-100k
$100-150k
>150k
Don't know/refused
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}